Google Maps API Outage

Incident Report for Cesium

Resolved

This incident has been resolved.
Posted May 08, 2025 - 03:12 EDT

Investigating

Intermittent failures for Google Photorealistic 3D Tiles.
Posted May 07, 2025 - 22:52 EDT
This incident affected: API (api.cesium.com) and Assets (assets.cesium.com).